Hay muchas razones para ejecutar aplicaciones como flatpaks, pero por lo general es que alguien quiere tener las últimas versiones lo antes posible.

Para mí, como usuario de Fedora que proporciona versiones actualizadas de aplicaciones no es una gran motivación.

Personalmente yo quiero ejecutar aplicaciones de forma más segura.

Suelo confiar en que el software proporcionado por Fedora y Flatpak sandbox.

Pero donde realmente prefiero usar paquetes de Flatpak a RPM son aplicaciones de terceros.

Normalmente estoy ejecutando versiones de desarrollo de Fedora. Pre-lanzamientos en mi máquina de pruebas con Rawhide, que una computadora portátil hogareña.

Han sido bastante estables para mí, incluidas las aplicaciones del repositorios de Fedora.

Desafortunadamente no es el caso para aplicaciones de terceros.

Sus autores generalmente no siguen de cerca el desarrollo de la distribución y, aunque muchos de ellos agrupan tanto como sea posible para evitar problemas con el cambio de dependencias, las cosas se terminan rompiendo.

Solía ​​usar el cliente de Spotify como un paquete de repositorios Negativo17. Pero cuando actualicé a F27, algo se rompió y dejó de funcionar.

Estoy bastante seguro de que se solucionó más adelante después de que la gente comenzó a informarlo, pero no quería dejar de usar Spotify por el momento y no tuve tiempo para depurar e informar el problema.

Así que cambié a Spotify flatpak y me ha funcionado desde entonces.

El problema que tuve con las primeras etapas de Fedora y Rawhide es que las dependencias de los complementos de GStreamer en RPMFusion generalmente se rompían.

Así que terminé sin códecs multimedia de sistema.

A menudo también era el caso de VLC desde el mismo repositorio. Luego cambié a VLC y GNOME MPV flatpaks. Problema resuelto.

El último ejemplo es Telegram. Hasta hace poco estaba usando la versión oficial. Ni siquiera se proporciona como un paquete de RPM.

Se tiene que descargar un archivo, descomprimir su contenido en una carpeta del directorio personal, ejecutar el archivo binario que crea un archivo de escritorio … no muy elegante en 2018, pero una vez que lo haces, simplemente funciona.

Me actualicé a F28 y Telegram de repente tardó mucho tiempo en arrancar. Se colgó en algún error de configuración de fuentes hasta que se agotó el tiempo y finalmente se inició. Se tardó fácilmente 1 minuto. Así que cambié a Telegram flatpak también.

Funciona de maravilla.

Entonces, lo que realmente aprecio de Flatpak es que las aplicaciones no dependen del sistema subyacente, por lo que si el sistema cambia, debido a la actualización a una nueva versión principal, las aplicaciones no se rompen.

Como dije, no es un problema tan importante para las aplicaciones proporcionadas por la distribución, pero ciertamente es un problema para las aplicaciones de terceros.

Y Flatpak lo resuelve para mí.

Deja un comentario

Deja un comentario

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.